[lkml]   [2009]   [Jan]   [8]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
    SubjectRe: Can't allocate resources for PCI video card behind bridge
    Cc-ing linux-pci and Jesse.

    On Thursday 08 January 2009, Connor Behan wrote:
    > Hello, I am trying to use two video cards. One is the built in ATI Rage
    > Mobility M3 AGP card which drives the screen of my laptop (Thinkpad a22m
    > 2628-S1U if that matters), the other is the ATI Radeon X1550 PCI card in
    > the Thinkpad Dock II which is supposed to drive an external monitor.
    > X1550 is a PCI-E chipset but my card is a PCI card with an onboard PCI
    > to PCI-E bridge. I first tried this with kernel 2.6.27 as packaged by
    > Archlinux and got the following startup errors:
    > pci 0000:00:04.0: BAR 7: can't allocate resource
    > pci 0000:00:04.0: BAR 8: can't allocate resource
    > pci 0000:00:04.0: BAR 9: can't allocate resource
    > I've seen this problem discussed in the archives and couldn't find what
    > looked like a fix. I WAS able to fix this by loading dock, pci_slot,
    > pci_hotplug and acpiphp and appending pci=assign-busses. However since
    > then I have run a package update to kernel and I am once again
    > getting the same problem even with the same modules and parameters. I
    > have since tried appending irqpoll, pci=bios, pci=routeirq and acpi=off
    > with no success. I have even rolled back my kernel to 2.6.27 (and the
    > headers and a few other packages) setup my system the way it was setup
    > before to the best of my knowledge but I still can't get the PCI card
    > working again. Another subtle change must be responsible.
    > Certain PCI devices in the dock are working such as the Cardbus slots...
    > but I could care less about them... is there a way I could tell the
    > kernel to prioritize the video card and sacrifice Cardbus slots first if
    > it can't allocate enough resources? Also my lspci output shows a large
    > gap 01:00.0 to 06:00.0 so some part of my system must have expected
    > other devices in that range. When I had the video card working it was
    > 02:00.0. I have tried changing the four IRQ numbers in the BIOS but this
    > is pointless at best and sometimes causes my soundcard to be disabled.
    > My dmesg, lspci and (trimmed) kernel config are pasted:
    > dmesg:
    > lspci:
    > .config:
    > I'm hoping for a solution that doesn't require recompiling the kernel
    > but I definitely would if that's necessary. In any event I'll be much
    > more vigilant about system updates if I get this working again.
    > Thank-you very much for your time.

     \ /
      Last update: 2009-01-08 20:59    [W:0.024 / U:7.100 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site