lkml.org 
[lkml]   [2009]   [Jan]   [5]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] tracing/kmemtrace: normalize the raw tracer event to the unified tracing API
On Mon, Jan 05, 2009 at 11:48:56AM -0500, Steven Rostedt wrote:
>
> On Tue, 30 Dec 2008, Ingo Molnar wrote:
>
> >
> > * Frederic Weisbecker <fweisbec@gmail.com> wrote:
> >
> > > kernel/trace/trace_kmemtrace.c | 345 ++++++++++++++++++++++++++++++++++++++++
> >
> > btw., i renamed this to kernel/trace/kmemtrace.c. Mentioning 'trace' twice
> > is enough already ;-)
>
> Should we rename all the kernel/trace/trace_(.*)\.c to kernel/trace/\1.c ?
>
> Although I do like the trace in the function name, because it groups them
> nicely together, and keeps ftrace.c and ring_buffer.c stand out from the
> rest.
>
> -- Steve
>

Or why not a subdirectory called "tracers" inside kernel/trace to store
the tracers files. This way, the core of tracing (ftrace.c/ring_buffer.c/trace_output.c/
/trace.c/trace_stat.c) can be found easily against the rest. Moreover, there is a risk that
the number of tracers will tend to increase by the time.



\
 
 \ /
  Last update: 2009-01-06 00:53    [W:0.081 / U:1.488 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site