lkml.org 
[lkml]   [2009]   [Jan]   [19]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] autofs: fix the wrong usage of the deprecated task_pgrp_nr()
On 01/19, Ian Kent wrote:
>
> On Sun, 2009-01-18 at 08:34 +0100, Oleg Nesterov wrote:
> > parse_options(&pgid) sets pgid = task_pgrp_nr() which uses the global
> > namespace. This is wrong, we use this pgid to find "struct pid" in the
> > current's namespace. Change parse_options() to use task_pgrp_vnr().
> >
> > Also do s/task_pgrp_nr/task_pgrp_vnr/ in the debugging printks.
> > checkpatch.pl complains about "line over 80 characters", but it should
> > blame the cuurent code, not the patch.
>
> This changelog entry doesn't really have anything that I can use to work
> out if this change might introduce regressions.
>
> It would be helpful to me if you could include:
> 1) A brief statement about what your trying to achieve and why.

First of all, I think this patch fixes a bug.

What we are doing in autofs_fill_super()->parse_options() path
is find_get_pid(task_pgrp_vnr(current)), this is wrong.

task_pgrp_vnr() reporst the pid_t in the global namespace, but
find_get_pid() searches "struct pid" in the current namespace.
We can get the wrong pid. I tried to document this in changelog.

Another reason is that task_pgrp_nr() is deprecated. We are wasting
2 words in signal_struct without good reason. Please look at

http://marc.info/?l=linux-kernel&m=123228947019281

> 2) The reason why task_pgrp_nr() has changed to task_pgrp_vnr() since
> you made the change (that is someone working on pid namespaces) to
> task_pgrp_nr().

see above.

> 3) Why you believe this change won't introduce a regression.

Ah, sorry. I forgot to mention this patch is only compile tested
(like the next one, but at least it has the note in changelog).

But again, I think this is bugfix.

Oleg.



\
 
 \ /
  Last update: 2009-01-19 08:13    [from the cache]
©2003-2014 Jasper Spaans. hosted at Digital Ocean