lkml.org 
[lkml]   [2009]   [Jan]   [19]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    From
    SubjectRe: [PATCH] autofs: fix the wrong usage of the deprecated task_pgrp_nr()
    Ian Kent wrote:
    > On Sun, 2009-01-18 at 08:34 +0100, Oleg Nesterov wrote:
    >> parse_options(&pgid) sets pgid = task_pgrp_nr() which uses the global
    >> namespace. This is wrong, we use this pgid to find "struct pid" in the
    >> current's namespace. Change parse_options() to use task_pgrp_vnr().
    >>
    >> Also do s/task_pgrp_nr/task_pgrp_vnr/ in the debugging printks.
    >> checkpatch.pl complains about "line over 80 characters", but it should
    >> blame the cuurent code, not the patch.
    >
    > This changelog entry doesn't really have anything that I can use to work
    > out if this change might introduce regressions.
    >
    > It would be helpful to me if you could include:
    > 1) A brief statement about what your trying to achieve and why.
    > 2) The reason why task_pgrp_nr() has changed to task_pgrp_vnr() since
    > you made the change (that is someone working on pid namespaces) to
    > task_pgrp_nr().
    > 3) Why you believe this change won't introduce a regression.
    >

    The other thing is also: isn't it high time to remove autofs 3? It has
    been unmaintained for at least 10 years now. I should know ;)

    -hpa

    --
    H. Peter Anvin, Intel Open Source Technology Center
    I work for Intel. I don't speak on their behalf.



    \
     
     \ /
      Last update: 2009-01-19 07:39    [W:0.023 / U:0.684 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site