lkml.org 
[lkml]   [2008]   [Sep]   [9]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH v2 05/13] PCI: cpci_hotplug: stop managing hotplug_slot->name
On Tue, Sep 09, 2008 at 04:00:27AM -0600, Alex Chiang wrote:
> We no longer need to manage our version of hotplug_slot->name
> since the PCI and hotplug core manage it on our behalf.
>
> Now, we simply advise the PCI core of the name that we would
> like, and let the core take care of the rest.

> -static void
> -make_slot_name(struct slot *slot)
> -{
> - snprintf(slot->hotplug_slot->name,
> - SLOT_NAME_SIZE, "%02x:%02x", slot->bus->number, slot->number);
> -}
>
>
> + scnprintf(name, SLOT_NAME_SIZE, "%02x:%02x", bus->number, i);
> +
> hotplug_slot->private = slot;

Unfortunately, our name is kind of crappy. Can we not give the user
anything better than this? I can't seem to find the CompactPCI
specification to see if we have a better name available.

I wonder if we can use DMI data on this class of machine. Scott?

--
Matthew Wilcox Intel Open Source Technology Centre
"Bill, look, we understand that you're interested in selling us this
operating system, but compare it to ours. We can't possibly take such
a retrograde step."


\
 
 \ /
  Last update: 2008-09-09 17:07    [W:0.159 / U:2.504 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site