[lkml]   [2008]   [Sep]   [3]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
    SubjectRe: [2.6.27] early exception - lockdep related?
    On Wed, Sep 3, 2008 at 10:28 AM, Luca Tettamanti <> wrote:
    > On Wed, Sep 3, 2008 at 8:52 AM, Peter Zijlstra <> wrote:
    >> On Tue, 2008-09-02 at 23:06 +0200, Luca Tettamanti wrote:
    >>> Hello,
    >>> I'm seeing an early exception (0e) - which seems related to lockdep - at
    >>> boot with many 2.6.27 kernels and I'm having troubles to track it down.
    >> Does it print one of these nice stack traces?
    > Of course not ;-) It dies before dumping the stack trace (or at least
    > it doesn't make to the console - that machine has a serial port, but
    > my notebook does not... I've ordered a usb-to-serial adapter).
    >>> The strange thing is that it comes and goes with different kernel
    >>> versions
    >> What kernel version did you generate the below with - and what config.
    > -rc2 is working, after that it's intermittent. The last kernel that I
    > tried is -git from a couple of days ago.
    >>> , but a "bad" kernel consistently fails across reboots. It also
    >>> seems to be sensitive to the configuration (attached)
    >> you seem to have forgotten that attachment.
    > Ops, will send as soon as I get home.

    Config is attached.

    I tried netconsole, but got not output. No luck with qemu either :S

    QEMU from SVN reports that:
    qemu: fatal: Trying to execute code outside RAM or ROM at 0x00000000000a0000

    KVM goes a bit further but dies due to an exception while the kernel
    is still executing in real mode.

    [unhandled content-type:application/octet-stream]
     \ /
      Last update: 2008-09-03 21:25    [W:0.036 / U:79.796 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site