[lkml]   [2008]   [Sep]   [22]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
    SubjectRe: [PATCH] UIO: Resend: Change driver name of uio_pdrv

    On Mon, Sep 22, 2008 at 10:08:36PM +0200, Hans J. Koch wrote:
    > On Fri, Sep 19, 2008 at 09:40:34AM +0200, Uwe Kleine-König wrote:
    > > Hello Hans,
    > >
    > > [Added Magnus Damm (= author of uio_pdrv_genirq) to Cc:]
    Note: Magnus' address seems to be wrong. I don't know a working one.

    > > > The generic UIO platform device driver should be given a unique driver ID and
    > > > not just "uio". This is especially important since we now have a similar driver
    > > > named uio_pdrv_genirq. Currently, there's no user of this driver in the
    > > > mainline kernel.
    > > I want to suggest to rename uio_pdrv_genirq to uio_genirq instead. In
    > > my eyes this would be more clear. IMHO the pdrv suffix doesn't yield
    > > more clearity because it is only used in a certain namespace---namely
    > > that of platform devices. So e.g.
    > >
    > > /sys/bus/platform/devices/uio_pdrv.0
    > >
    > > isn't any better than
    > >
    > > /sys/bus/platform/devices/uio.0
    > Well, I just want to avoid using the generic "uio" identifier for a
    > single driver. A sysfs entry like this last one looks like a kind of
    > "standard way" how a UIO platform device driver should be done.
    I wonder that you don't have this impression with "uio_pdrv".

    > I'd like
    > to avoid that impression. It can be "uio_pdrv" or "uio_pdrv_genirq", but
    > there's no standard "uio" way of handling platform devices.
    I thought the driver in discussion is kind of a standard way to create a
    platform driver using uio.
    (At least you called it "generic UIO platform device driver" above :-)

    > >
    > > . Looking at the name of other platform drivers using
    > >
    > > git grep -E '_pdrv(_.*)?"'
    > >
    > > I get three false positives[1] and uio_pdrv_genirq (driver and some
    > > users in arch/sh/kernel/cpu/sh4a/setup-sh7343.c). So the _pdrv suffix
    > > doesn't seem very common.
    > I don't really understand what you mean here.
    I tried to point out that uio_pdrv_genirq is (probably) the only
    platform driver that has _pdrv in its name.

    Best regards
    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to
    More majordomo info at
    Please read the FAQ at

     \ /
      Last update: 2008-09-22 22:41    [from the cache]
    ©2003-2014 Jasper Spaans. hosted at Digital Ocean