lkml.org 
[lkml]   [2008]   [Sep]   [20]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: kernel.h: add ARRAY_AND_SIZE() macro to complement ARRAY_SIZE().
[Christer Weinigel - Sat, Sep 20, 2008 at 04:28:19PM +0200]
...
>
> In my opinion, making platform_add_devices into a magic macro is
> actually worse, since the same construct (array, ARRAY_SIZE(array)) is
> used in many places, so one would have to do the same thing over and
> over again for every function. In that case it's better to have to
> learn one macro once, and the ALL_CAPITALS should make it obvious that
> it is a macro.
>
> /Christer
>

Well, can't agree with you :) It's my _presonal_ opinion.
You could define it as

static inline int platform_add_devices_array(struct platform_device **devs)
{
return platform_add_devices(devs, ARRAY_SIZE(devs));
}

for me it would look much better then hide args by MACRO.
And I don't feel any hard about to use platform_add_devices
with TWO arguments. But I repeat - it's my _personal_ opinion.

- Cyrill -


\
 
 \ /
  Last update: 2008-09-20 16:47    [W:0.062 / U:0.328 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site