[lkml]   [2008]   [Sep]   [19]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH] UIO: Resend: Change driver name of uio_pdrv
Hello Hans,

[Added Magnus Damm (= author of uio_pdrv_genirq) to Cc:]

On Thu, Sep 18, 2008 at 11:03:07PM +0200, Hans J. Koch wrote:
> The patch below was already discussed and accepted:
> It somehow got lost (probably because I forgot it when I sent my queue
> to Greg...). So, here it is again:
> -------------8<------------------------
> The generic UIO platform device driver should be given a unique driver ID and
> not just "uio". This is especially important since we now have a similar driver
> named uio_pdrv_genirq. Currently, there's no user of this driver in the
> mainline kernel.
I want to suggest to rename uio_pdrv_genirq to uio_genirq instead. In
my eyes this would be more clear. IMHO the pdrv suffix doesn't yield
more clearity because it is only used in a certain namespace---namely
that of platform devices. So e.g.


isn't any better than


. Looking at the name of other platform drivers using

git grep -E '_pdrv(_.*)?"'

I get three false positives[1] and uio_pdrv_genirq (driver and some
users in arch/sh/kernel/cpu/sh4a/setup-sh7343.c). So the _pdrv suffix
doesn't seem very common.

Just my 0.02€

Best regards

[1] in drivers/scsi/megaraid.c
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

 \ /
  Last update: 2008-09-19 09:43    [W:0.046 / U:2.188 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site