lkml.org 
[lkml]   [2008]   [Sep]   [15]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
Subjectext3 mount infinite loop over orphan list issue, please release 2.6.27
Hello,

Over the weekend, due to a crash, I ran into the ext3 mount infinite
loop over orphan list issue. This was on Ubuntu 8.04. I tried many
things, including using 18 month old distributions, nothing works. Only
solution is to boot off a alpha version of next Ubunuty which has the
2.6.27 kernel (rc1 has the fix), more details are below:

Can you please release 2.6.27 so that it can make it to stable
distributions.

Needless to say, this is bad. End Users should not have to go through
kernel patches, logs and try out alpha OSes to boot up from a crash and
save their filesystem contents.

Thanks
Amit

-------------------------------------------------

After crash, Ubuntu does not come up, ext3 root filesystem fails to mount
https://bugs.launchpad.net/bugs/270371


** Affects: ubuntu
Importance: Undecided
Status: New


** Tags: ext3 kernel

--

Hello,

Ubuntu 8.0.4 crashed while opening a .mpg in totem player. it was a hang, no response to keyboard, the mouse was moving but not response to clicks. Ctrl+Alt+F1, etc did not open a console.
On a reboot, the system did not come up. Neither did rescue mode. Rescue mode shows the last few kernel messages were
ext3: recovery required
Orphan cleanup on readonly filesystem

which means Root filesystem with ext3 fails to mount.

I then tried booting with the 8.04 live CD, even the CD never boots up.
When running without the flags quiet & slpash, again the above
statements are the last printed.

I tried all of following Ubuntu live cds, 8.04.1, 7.10, 7.04, no luck.
The message is not printed in the last one, but it is stuck.

Does anyone know of any solution? Is there a way of not loading the
rootfs from the live CD?

I also found there is a fix for infinite loop in 2.6.27
(http://www.kernel.org/pub/linux/kernel/v2.6/testing/ChangeLog-2.6.27-rc1),
but am not sure if this is that issue

Thanks
Amit




------------------------------------

Ok, so it was the problem from the link, rebooting from a live cd for Intrepid (Ubunty 8.10) Alpha 5 which has kernel 2.6.27 fixed it.
Incase your box hangs or goes in an infinite loop after a crash, this is one of the solutions.

It printed some error messages such as bad orphan node, did you run
e2fsck, n_inode = 1 , etc and then rebooting off the installed Ubuntu
worked.

Should mention, this is bad. Users should not have to go through kernel
patches, logs and try out alpha OSes to boot up from a crash.

Amit




\
 
 \ /
  Last update: 2008-09-16 00:17    [W:0.037 / U:3.924 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site