lkml.org 
[lkml]   [2008]   [Sep]   [10]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 0/4] add a helper function, is_buffer_dma_capable()

* Joerg Roedel <joerg.roedel@amd.com> wrote:

> On Wed, Sep 10, 2008 at 01:06:45AM +0900, FUJITA Tomonori wrote:
> > This patchset adds a trivial helper function, is_buffer_dma_capable()
> > and cleans up some IOMMU implementations. This function is to to see
> > if a memory region is DMA-capable or not with the arguments, the
> > dma_mask (or coherent_dma_mask) of a device and the address and size
> > of a memory region. It's useful for IOMMUs that don't do virtual
> > mappings at all times.
> >
> > The patch for swiotlb is a bug fix (the rest are just
> > cleanups). Currently, swiotlb doesn't take account of the size of a
> > memory region to see if if the memory region is DMA-capable.
>
> Good idea. This patchset increases the readability of the software
> dma-api implementations.
>
> Acked-by: Joerg Roedel <joerg.roedel@amd.com>

applied to tip/x86/iommu:

2797982: swiotlb: convert swiotlb to use is_buffer_dma_capable helper function
49fbf4e: x86: convert pci-nommu to use is_buffer_dma_capable helper function
ac4ff65: x86: convert gart to use is_buffer_dma_capable helper function
636dc67: add is_buffer_dma_capable helper function

thanks!

Ingo


\
 
 \ /
  Last update: 2008-09-10 11:37    [W:0.192 / U:0.216 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site