lkml.org 
[lkml]   [2008]   [Aug]   [7]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: PCI: Limit VPD length for Broadcom 5708S
Date
On Tuesday, August 5, 2008 11:49 am Dean Hildebrand wrote:
> > I have no idea if 5706S and 5709S also needs this truncation ofVPDlength
>
> It seems that our IBM Blade servers using 5706S also require this
> fix. We have confirmed that the patch below works on 2.6.27-rc1.
>
>
> diff -uprN linux-2.6.27-rc1/drivers/pci/quirks.c
> linux-2.6.27-rc1-fix/drivers/pci/quirks.c
> --- linux-2.6.27-rc1/drivers/pci/quirks.c 2008-08-05
> 10:51:42.000000000 -0700
> +++ linux-2.6.27-rc1-fix/drivers/pci/quirks.c 2008-08-05
> 10:50:57.000000000 -0700
> @@ -1756,9 +1756,10 @@ DECLARE_PCI_FIXUP_EARLY(PCI_VENDOR_ID_VI
> */
> static void __devinit quirk_brcm_570x_limit_vpd(struct pci_dev *dev)
> {
> - /* Only disable the VPD capability for 5706, 5708, and 5709
> rev. A */
> + /* Only disable the VPD capability for 5706, 5706S, 5708, and
> 5709 rev. A */
> if ((dev->device == PCI_DEVICE_ID_NX2_5706) ||
> (dev->device == PCI_DEVICE_ID_NX2_5708) ||
> + (dev->device == PCI_DEVICE_ID_NX2_5706S) ||
> ((dev->device == PCI_DEVICE_ID_NX2_5709) &&
> (dev->revision & 0xf0) == 0x0)) {
> if (dev->vpd)

Looks fine. Can you respin against my for-linus branch and resubmit with a
signed-off-by and full changelog?

Thanks,
Jesse


\
 
 \ /
  Last update: 2008-08-07 17:59    [W:0.058 / U:2.528 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site