lkml.org 
[lkml]   [2008]   [Aug]   [27]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: Is SKAS still required for UML
On Wed, Aug 27, 2008 at 12:57:53PM -0400, Jan Engelhardt wrote:
> the UML page at http://user-mode-linux.sourceforge.net/old/skas.html
> mentions that "The UML kernel is present in the address space of each of
> its processes, and, by default, is writeable".

That stuff, as you can see by the "old" in the URL, is old.

Since skas0 became the default, that statement is no longer true.
>
> I tried to put this to a test, and actually failed to modify the
> UML kernel/memory image from within it. I had a simple kernel module
> with 'int val = 2;' and upon loading this, done printk("Val is at %p\n",
> &val); to get to know the address. A userspace program inside the UML
> then tried to dereference that address and read the value, but that
> ended in a segfault. /proc/xxx/maps also does not show the UML kernel
> being mapped in any process inside the UML. Note that I was running in
> SKAS0 mode, both host and guest are all 64-bit. Is the NX bit of the
> 64-bit platform securing things off, or has SKAS3 become sort of
> obsolete?

SKAS3 is still a significant performance boost.

Jeff

--
Work email - jdike at linux dot intel dot com


\
 
 \ /
  Last update: 2008-08-27 21:09    [from the cache]
©2003-2011 Jasper Spaans