lkml.org 
[lkml]   [2008]   [Aug]   [25]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: latest -git: WARNING: at arch/x86/kernel/ipi.c:123 send_IPI_mask_bitmask+0xc3/0xe0()
On Sun, Aug 24, 2008 at 8:13 PM, Dave Jones <davej@redhat.com> wrote:
> On Sun, Aug 24, 2008 at 07:45:48PM +0200, Vegard Nossum wrote:
> > Why is MHz on 375!? I tried cpufreq-selector, but nothing changed. Maybe
> >
> > calling acpi_cpufreq_init+0x0/0x90
> > initcall acpi_cpufreq_init+0x0/0x90 returned -19 after 0 msecs
>
> -ENODEV. Because you don't have frequency scaling capable CPU.
>
> > Okay, now I used cpufreq-selector to change to "ondemand" governor,
> > and MHz goes back to 3000. Weird. Why would "performance" governor put
> > my machine to a constant 375?
>
> Probably because you're using p4-clockmod, and it's crap.

On Sun, Aug 24, 2008 at 7:59 PM, H. Peter Anvin <hpa@kernel.org> wrote:
> That would be a problem... I presume this problem is independent of the
> patch, though?

I sorted it -- thanks! It turned out to be pretty obscure; my tty
setting for the receiving end of the serial console was set to echo.
So when the machine booted, it was echoing lots of characters into the
Fedora 7 init, which would prompt for the starting of cpuspeed
initscript. Turning off echo for the tty was what triggered the
slowness; removing cpuspeed from the runlevel entirely solved the
problem.

Don't know why cpuspeed would select a governor which runs the CPU at
a constant 300 MHz, though.


Vegard

--
"The animistic metaphor of the bug that maliciously sneaked in while
the programmer was not looking is intellectually dishonest as it
disguises that the error is the programmer's own creation."
-- E. W. Dijkstra, EWD1036


\
 
 \ /
  Last update: 2008-08-25 20:33    [W:0.070 / U:10.144 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site