lkml.org 
[lkml]   [2008]   [Aug]   [21]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: writable packet CD mounting in 2.6.26.x?
From
Date
[Back now, sorry for the delay, but I didn't even have mobile phone access
in my tent, let alone an Internet connection. I had lots of running water,
though, lots and lots and lots: I'm not sure it stopped raining for more
than ten minutes in that whole week.]

On 8 Aug 2008, Alexey Dobriyan uttered the following:
> On Fri, Aug 08, 2008 at 07:14:37AM +0400, Alexey Dobriyan wrote:
>> > Anyone got any ideas? There are no suspicious-looking changes in
>> > pktcdvd.c itself, so maybe this lies deeper in the block layer. Or
>> > perhaps I'm mounting it wrong in some obscure way.
>
> Ho-hum, I get ->mmc3_profile = 9 here in both .25 anf .26 kernel, so I
> can't meaningfully debug it here. :-(
>
> Does it -EROFS because of pkt_writable_disc()? If yes, apply this patch
> too.

Too? Was there another patch?

I see

pkt_probe_settings: 00 00 00 ac 00 00 00 00 00 00 00 00
pkt_probe_settings: pd = edd80ee0, ->mmc3_profile = 0
pkt_writable_disc: pd = edd80ee0, ->mmc3_profile = 0

Thus we get 0 back from pkt_writable_disc(). (This drive is a Yamaha
CRW3200E, at least five years old, but it's a CD-RW so should definitely
support MMC3, I'd have thought.)

That probe result looks really odd. Maybe something's wrong with sg?

(This is an ATAPI device, and I'm using the old IDE layer, not
libata. Maybe I should switch and see if libata works better...)


\
 
 \ /
  Last update: 2008-08-22 01:27    [W:0.091 / U:6.456 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site