lkml.org 
[lkml]   [2008]   [Aug]   [17]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] BUILD_BUG_ON sucks
On Sun, 17 Aug 2008 08:19:06 -0400 Theodore Tso <tytso@mit.edu> wrote:

> On Sat, Aug 16, 2008 at 10:46:58AM -0700, Andrew Morton wrote:
> > > what this code is supposed to do?
> > >
> > > journal = handle->h_transaction->t_journal;
> > > if (!journal_set_features(journal, 0, 0, JFS_FEATURE_INCOMPAT_REVOKE)) {
> > > J_ASSERT (!"Cannot set revoke feature!");
> > > ^^^^
> >
> > lol. It's been there since I merged ext3 in 2.4.15. Probably it was
> > in sct's ext3 patches in the RH kernel.
> >
> > Don't change it - it might be important!
>
> Heh! Well, it does the right thing, and doesn't take any extra text
> space assuming a vaguely competent C compiler optimizer. :-)
>
> I'm pretty sure that back in the 2.4 days, we didn't have BUG_ON. We
> should do a s/J_ASSERT/BUG_ON/g pass over all of fs/jbd and fs/jbd2.
> I'll submit patches for application when the 2.6.27 merge window opens
> up --- or is this an obvious enough and safe enough transformation
> that it will get accepted mainline at this point?
>

May as well get it over and done with.

We presently have a mix of J_ASSERT, J_ASSERT_JH and J_ASSERT_BH. That
will become BUG_ON, J_ASSERT_JH and J_ASSERT_BH. Which a is slightly
unpleasing loss of consistency but whatever.




\
 
 \ /
  Last update: 2008-08-17 18:37    [W:0.058 / U:26.772 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site