lkml.org 
[lkml]   [2008]   [Aug]   [15]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: ath5k on the Acer Aspire One
On Fri, Aug 15, 2008 at 4:21 AM, J.A. Magallón <jamagallon@ono.com> wrote:
> I'm using 2.6.26.2 from Mandriva cooker.
>
> I'm also thinking its a soft/encryption problem:

The encryption fixes I know about for WPA should already be in 2.6.26. But
ath5k uses mac80211 for encryption so if it is encryption related, then it's
in the interface code between them, or else more wireless cards would have
the problem.

> one:~# wpa_supplicant -iwlan0 -c/etc/wpa_supplicant.conf -Dwext -d
> Initializing interface 'wlan0' conf '/etc/wpa_supplicant.conf' driver 'wext' ctrl_interface 'N/A' bridge 'N/A'
> Configuration file '/etc/wpa_supplicant.conf' -> '/etc/wpa_supplicant.conf'
> Reading configuration file '/etc/wpa_supplicant.conf'
> ctrl_interface='/var/run/wpa_supplicant'
> eapol_version=1
> ap_scan=1
> fast_reauth=1
> Line 771: removed CCMP from group cipher list since it was not allowed for pairwise cipher
> Priority group 0
> id=0 ssid='werewolf'
> Initializing interface (2) 'wlan0'
> SIOCGIWRANGE: WE(compiled)=22 WE(source)=21 enc_capa=0xf
> capabilities: key_mgmt 0xf enc 0xf
> WEXT: Operstate: linkmode=1, operstate=5
> Own MAC address: 00:1f:e2:bc:8c:01
> wpa_driver_wext_set_wpa
> wpa_driver_wext_set_key: alg=0 key_idx=0 set_tx=0 seq_len=0 key_len=0
> wpa_driver_wext_set_key: alg=0 key_idx=1 set_tx=0 seq_len=0 key_len=0
> wpa_driver_wext_set_key: alg=0 key_idx=2 set_tx=0 seq_len=0 key_len=0
> wpa_driver_wext_set_key: alg=0 key_idx=3 set_tx=0 seq_len=0 key_len=0
> wpa_driver_wext_set_countermeasures
> ioctl[SIOCSIWAUTH]: Operation not supported
> WEXT auth param 4 value 0x0 - wpa_driver_wext_set_drop_unencrypted
> RSN: flushing PMKID list in the driver
> Setting scan request: 0 sec 100000 usec
> EAPOL: SUPP_PAE entering state DISCONNECTED
> EAPOL: KEY_RX entering state NO_KEY_RECEIVE
> EAPOL: SUPP_BE entering state INITIALIZE
> EAP: EAP entering state DISABLED
> Added interface wlan0
> RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
> Wireless event: cmd=0x8b06 len=8
> State: DISCONNECTED -> SCANNING
> Starting AP scan (broadcast SSID)
> Trying to get current scan results first without requesting a new scan to speed up initial association
> Received 0 bytes of scan results (0 BSSes)
> CTRL-EVENT-SCAN-RESULTS
> Selecting BSS from priority group 0
> Try to find WPA-enabled AP
> Try to find non-WPA AP
> No suitable AP found.
> Setting scan request: 0 sec 0 usec
> Starting AP scan (broadcast SSID)
> Scan requested (ret=0) - scan timeout 5 seconds
> EAPOL: disable timer tick
> RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
> Wireless event: cmd=0x8b19 len=8
> Received 0 bytes of scan results (0 BSSes)
> CTRL-EVENT-SCAN-RESULTS
> Selecting BSS from priority group 0
> Try to find WPA-enabled AP
> Try to find non-WPA AP
> No suitable AP found.
> ...

It looks like you didn't get any scan results. Does 'iwlist wlan0 scan'
work?

CCing ath5k-devel, you'll probably get more help there.

--
Bob Copeland %% www.bobcopeland.com
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2008-08-15 15:43    [from the cache]
©2003-2011 Jasper Spaans