[lkml]   [2008]   [Jul]   [3]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
    SubjectRe: b43 locks the machine when resuming after suspend to disk
    On Thu, 3 Jul 2008, Johannes Berg wrote:

    > This seems very odd though, Giacomo, are you sure it also happens if you
    > unload the module?

    yes, absolutely (unfortunately). I can unload the module before suspending,
    reload it after resuming, same result; I can actually do any number of
    suspend/resumes, unload and reload the modules any number of times,
    everything still works until I try to ifconfig up the interface, then it
    hangs solid. I also tried old-style suspend to disk, suspend2, user-space
    suspend... exactly the same.

    I am now compining a kernel with the patch you sent, to see whether this
    improves things. I will let you know. By the way, is there a module
    debugging option I could use to cause the b43 and/or mac80211 modules to use
    lots of printk's, so that I could at least give you a hint as to where the
    code hangs?

    Thanks, bye

    P.S. please CC replies to me, I'm not on the list(s)


    Giacomo Mulas <>

    Str. 54, Loc. Poggio dei Pini * 09012 Capoterra (CA)

    Tel. (OAC): +39 070 71180 248 Fax : +39 070 71180 222
    Tel. (UNICA): +39 070 675 4916

    "When the storms are raging around you, stay right where you are"
    (Freddy Mercury)

     \ /
      Last update: 2008-07-03 14:39    [W:0.020 / U:2.204 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site