lkml.org 
[lkml]   [2008]   [Jul]   [17]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    From
    SubjectRe: 2.6.26-rc9-git9 doesn't boot on Macintel
    YH,
    I have CONFIG_PCIEASPM=y set in .config (since I am using
    Fedora 9, I copied the .config from the redhat 2.6.26 rpm build
    as my .config and ran 'make oldconfig'). I'll try rebuilding the
    kernel with CONFIG_PCIEASPM_DEBUG=y and see if that provides
    any insights.
    Jack
    On Wed, Jul 16, 2008 at 11:48:19PM -0700, Yinghai Lu wrote:
    > On Wed, Jul 16, 2008 at 11:18 PM, Jack Howarth
    > <howarth@bromo.msbb.uc.edu> wrote:
    > > YH,
    > > Using the debug patches and your mmconfig patch as well as the kernel
    > > options 'debug initcall_debug apic=verbose pci=routeirq", I see the following
    > > messages that don't scroll off screen...
    > >
    > > PCI: 0000:00:1f.1 reg 10 io port: [ 40d8, 40df]
    > > PCI: 0000:00:1f.1 reg 14 io port: [ 40ec, 40ef]
    > > PCI: 0000:00:1f.1 reg 18 io port: [ 40d0, 40d7]
    > > PCI: 0000:00:1f.1 reg 1c io port: [ 40e8, 40eb]
    > > PCI: 0000:00:1f.1 reg 20 io port: [ 40b0, 40bf]
    > > pci 0000:00.1f.1: calling pci_fixup_transparent_bridge+0x0/0x2a
    > > PCI: Found 0000:00:1f.2 [8086/27c4] 000101 00
    > > PCI: 0000:00:1f.2 reg 10 io port: [ 40c8, 40cf]
    > > PCI: 0000:00:1f.2 reg 14 io port: [ 40e4, 40e7]
    > > PCI: 0000:00:1f.2 reg 18 io port: [ 40c0, 40c7]
    > > PCI: 0000:00:1f.2 reg 1c io port: [ 40e0, 40e3]
    > > PCI: 0000:00:1f.2 reg 20 io port: [ 40a0, 40af]
    > > PCI: 0000:00:1f.2 reg 24 32bit mmio: [d8405000, d84053ff]
    > > pci: 0000:00:1f.2 calling pci_fixup_transparent_bridge+0x0/0x2a
    > > PCI: Found 0000:00:1f.3 [8086/27da] 000c05 00
    > > PCI: 0000:00:1f.3 reg 20 io port: [ efa0, efbf]
    > > PCI: 0000:00:1f.3: calling pci_fixup_transparent_bridge+0x0/0x2a
    > > PCI: Fixups for bus 0000:00
    > > PCI: Scanning behind PCI bridge 0000:00:01.0, config 010100, pass 0
    > > PCI: Scanning bus 0000:01
    > > PCI: Found 0000:01:00.0 [1002/71c5] 000300 00
    > > PCI: 0000:00:01:00.0 reg 10 32bit mmio: [c0000000, cfffffff]
    > > PCI: 0000:00:01:00.0 reg 14 io port: [ 3000, 30ff]
    > > PCI: 0000:00:01:00.0 reg 18 32bit mmio: [d8300000, d830ffff]
    > >
    > should get
    > PCI: Fixups for bus 0000:01
    > PCI: Transparent bridge - 0000:00:01.0
    > PCI: bridge 0000:00:01.0 io port: [3000, 3fff]
    > PCI: bridge 0000:00:01.0 32bit mmio: ...
    > PCI: Bus scan for 0000:01 returning with max=01
    >
    > Do you have CONFIG_PCIEASPM in your config?
    >
    > YH


    \
     
     \ /
      Last update: 2008-07-17 13:59    [W:0.023 / U:0.172 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site