lkml.org 
[lkml]   [2008]   [Jun]   [10]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] nommu: fix kobjsize() for SLOB and SLUB, v2.
On Tue, 10 Jun 2008, Vegard Nossum wrote:

> Are you sure it shouldn't be virt_addr_valid()? If yes, can you please
> explain the difference? Thanks :-)

from include/asm-x86/page.h

#define virt_addr_valid(kaddr) pfn_valid(__pa(kaddr) >> PAGE_SHIFT)

#define virt_to_page(kaddr) pfn_to_page(__pa(kaddr) >> PAGE_SHIFT)


Yes virt_addr_valid is better to use. I was thinking too much using the
basic ops.




\
 
 \ /
  Last update: 2008-06-10 20:33    [from the cache]
©2003-2011 Jasper Spaans