[lkml]   [2008]   [May]   [5]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH 1/1] Replace down_trylock() with down_try(), reverse return values.
On Mon, May 05, 2008 at 04:09:12PM +1000, Rusty Russell wrote:
> > Given that people are actively trying to kill struct semaphore I don't
> > think doing a big search and rename is a good idea right now.
> If it goes away before the 2.6.27 merge window, great. But I don't see that
> happening, so let's clean up this horror. I cc'd all the people effected in
> the hope that it will prod some of them towards mutexes anyway.

.27 might not be doable but .28 seems probable if willy and co are
continuing to churn like they do currently.

> > (And I also really hate the name down_try, but when it goes away that's
> > rather void and we can spare the discussion)
> Ideas? down() is pretty bad, down_try() matches it.

The trylock is a convention for real locking function, so having one
stand out would be nasty. Then again a semaphore is not just a simple
lock but a higher level locking primitive, so a down_nowait might make
sense because we don't encode the lock anywhere else either

 \ /
  Last update: 2008-05-05 08:15    [W:0.024 / U:3.828 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site