[lkml]   [2008]   [May]   [5]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH 1/1] Replace down_trylock() with down_try(), reverse return values.
On Mon, May 05, 2008 at 01:56:35AM +0000, Rusty Russell wrote:
> down_trylock() returns 1 on failure, 0 on success. This differs from
> spin_trylock(), mutex_trylock() and common sense. Or as ocfs2 put it
> "kernel 1, world 0".
> Rename it to down_try() (which makes more sense anyway), and reverse
> it. Fortunately there aren't a huge number of callers left.
> I took the liberty of reversing the sense of usb_trylock_device()
> without renaming it: it's only used in one place anyway.

Given that people are actively trying to kill struct semaphore I don't
think doing a big search and rename is a good idea right now.

(And I also really hate the name down_try, but when it goes away that's
rather void and we can spare the discussion)

 \ /
  Last update: 2008-05-05 08:01    [W:0.054 / U:2.712 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site