[lkml]   [2008]   [May]   [5]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [patch 13/15] vfs: utimes cleanup
On Mon, May 05, 2008 at 11:54:54AM +0200, Miklos Szeredi wrote:
> From: Miklos Szeredi <>
> Untange the mess that is do_utimes()

A good idea to untangle this, but I'm not entirely happy with how it's

utimes_need_permission is a good helper and fine with me.

utimes_common is a good idea aswell, but I'd rather take the permission
checks into it aswell, even if that means a little flag telling if
file->f_mode should be checked or vfs_permission().

do_fd_utimes sounds fine, but I don't like that name. do_futimes maybe?

and when the fd-side is sorted out the path side should probably be a
helper aswell. Then sys_utime/sys_utimes/arhc bits could call it directly,
with the initial check in do_utimes separated out into a helper ala
utimes_need_permission. do_utimes should probably become do_futimesat
at the point.

 \ /
  Last update: 2008-05-05 13:33    [W:0.070 / U:10.252 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site