lkml.org 
[lkml]   [2008]   [May]   [4]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 1/1] DEBUGFS: Fixing name for debug fs
Hi Arnd,

This is question up to PowerPC guys not to me.
of_debugfs_root sounds good.

M


>> This change is made because powerpc_debugfs_root is arch
>> specific name.
> ...
>>
>> static int powerpc_debugfs_init(void)
>> {
>> - powerpc_debugfs_root = debugfs_create_dir("powerpc", NULL);
>> + debugfs_root = debugfs_create_dir("powerpc", NULL);
>>
>
> You left the name as "powerpc", which sort of defeats the purpose of your
> patch. Files in debugfs are by definition not part of the ABI, so it's
> actually possible to change this as well. How about making this "of"
> instead of "powerpc"?
>
> Arnd <><
>



\
 
 \ /
  Last update: 2008-05-04 10:57    [W:0.029 / U:30.400 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site