lkml.org 
[lkml]   [2008]   [May]   [26]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: [Bug #10749] the system doesn't shutdown
Date
On Sunday 25 May 2008, Riccardo Gori wrote:
> On Monday 26 May 2008 00:19:09 Bartlomiej Zolnierkiewicz wrote:
> > Hi,
> >
> > On Saturday 24 May 2008, Rafael J. Wysocki wrote:
> > > This message has been generated automatically as a part of a report
> > > of recent regressions.
> > >
> > > The following bug entry is on the current list of known regressions
> > > from 2.6.25. Please verify if it still should be listed.
> > >
> > >
> > > Bug-Entry : http://bugzilla.kernel.org/show_bug.cgi?id=10749
> > > Subject : the system doesn't shutdown
> > > Submitter : Riccardo <goric@trivenet.it>
> > > Date : 2008-05-19 09:00 (6 days old)
> >
> > Riccardo, thanks for bisecting the problem. Could you also attach dmesgs
> > for "good" and "bad" kernels at bugzilla entry (so we can see if there are
> > any clues for solving the regression in messages printed by the driver)?
> >
> > Also does the following patch help (we should always setup PCI device
> > with pci_enable_device() before using it, my patch changed it)?
> >
> > ---
> > drivers/ide/pci/sis5513.c | 5 +++++
> > 1 file changed, 5 insertions(+)
> >
> > Index: b/drivers/ide/pci/sis5513.c
> > ===================================================================
> > --- a/drivers/ide/pci/sis5513.c
> > +++ b/drivers/ide/pci/sis5513.c
> > @@ -569,6 +569,11 @@ static int __devinit sis5513_init_one(st
> > {
> > struct ide_port_info d = sis5513_chipset;
> > u8 udma_rates[] = { 0x00, 0x00, 0x07, 0x1f, 0x3f, 0x3f, 0x7f, 0x7f };
> > + int rc;
> > +
> > + rc = pci_enable_device(dev);
> > + if (rc)
> > + return rc;
> >
> > if (sis_find_family(dev) == 0)
> > return -ENOTSUPP;
>
>
> Hello,
> I'm bisecting again the kernel because I think I made something wrong.
>
> I don't think that is this the first bad commit because, after bisecting, I
> tried to git reset hard to that commit 3 times and build the kernel, and once
> the problem was not present. I'm really sorry.
>
> This is the output of dmesg when the problem is present:
>
> # dmesg
> r (psparse-0537): Method parse/execution failed [\ISMI] (Node f7c18630),
> AE_NO_MEMORY
> ACPI Error (psparse-0537): Method parse/execution failed
> [\_SB_.PCI0.PX40.MIDI._STA] (Node f7c1ef68), AE_NO_MEMORY
> ACPI Error (exregion-0164): Could not map memory at F7C218943FFFFF00, size 200
> [20070126]
> ACPI Exception (evregion-0420): AE_NO_MEMORY, Returned by Handler for
> [SystemMemory] [20070126]
> ACPI Error (psparse-0537): Method parse/execution failed [\ISMI] (Node
> f7c18630), AE_NO_MEMORY
> ACPI Error (psparse-0537): Method parse/execution failed
> [\_SB_.PCI0.PX40.GAME._STA] (Node f7c1eedc), AE_NO_MEMORY

[...]

> Sorry again

No problem and thanks for quickly & honestly reporting it (instead
of silently going away leaving us scratching our heads for months)...

[ + wrong bisect resulted in a valid bugfix patch, cool! ]

Thanks,
Bart


\
 
 \ /
  Last update: 2008-05-26 21:27    [W:0.204 / U:8.392 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site