lkml.org 
[lkml]   [2008]   [May]   [26]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: [PATCH 14/40] ide-floppy: merge idefloppy_transfer_pc() and idefloppy_transfer_pc1()
Date
On Wednesday 21 May 2008, Borislav Petkov wrote:
> On Sun, May 18, 2008 at 08:56:33PM +0200, Bartlomiej Zolnierkiewicz wrote:
> > * Check IDEFLOPPY_FLAG_ZIP_DRIVE flag in idefloppy_transfer_pc1()
> > and skip idefloppy_transfer_pc2()-phase if the flag is not set.
> >
> > * Always use idefloppy_transfer_pc1() in idefloppy_issue_pc()
> > and remove no longer needed idefloppy_transfer_pc().
>
> ... and also probably mv idefloppy_transfer_pc1() to something like
> idefloppy_start_transfer_pc() and rename idefloppy_transfer_pc2() to something
> more appropriate like e.g. idefloppy_do_transfer_pc() or similar and do away
> with those misleading names and probably even the comments are superfluous then.

Probably the most intuitive would be to do:

idefloppy_transfer_pc1() -> idefloppy_transfer_pc()

and

idefloppy_transfer_pc2() -> idefloppy_do_transfer_pc()

but I don't feel too strong about it and welcome other ideas
(preferably in form of patches :).

Thanks,
Bart


\
 
 \ /
  Last update: 2008-05-26 21:27    [W:0.086 / U:1.868 seconds]
©2003-2017 Jasper Spaans. hosted at Digital OceanAdvertise on this site