lkml.org 
[lkml]   [2008]   [May]   [23]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 0 of 4] mm+paravirt+xen: add pte read-modify-write abstraction


On Fri, 23 May 2008, Jeremy Fitzhardinge wrote:
>
> This series adds the pte_rmw_start() and pte_rmw_commit() operations,
> which change this sequence to:
>
> ptent = pte_rmw_start(mm, addr, pte);
> ptent = pte_modify(ptent, newprot);
> /* ... */
> pte_rmw_commit(mm, addr, pte, ptent);

Can you please rename these.

It's not a general "read-modify-write" operation on the PTE, and this
*only* works for changing protection details. In particular, you cannot
use pte_rmw_start/commit to change the actual page. So it's very much
about just protection bits.

It should probably also be called ptep_xyz(), since it takes a pte
pointer, not a pte.

So maybe calling it "ptent = ptep_modify_prot_start(..)" ...
"ptep_modify_prot_commit(..)" or something.

Linus


\
 
 \ /
  Last update: 2008-05-23 21:01    [W:0.105 / U:1.208 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site