lkml.org 
[lkml]   [2008]   [May]   [20]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: [PATCH 0/4] Fix forcedeth hibernate/wake-on-lan problems
Date
On Sunday, 18 of May 2008, Tobias Diedrich wrote:
> Tobias Diedrich wrote:
> > Note that so far this is only tested on my system with hibernate
> > using the 'shutdown' method.
>
> Ok, I've run tests now:
>
> First Windoze:
> Windoze, Standby (equiv. to Linux 'mem' state): WOL borked, resumes fine
> Windoze, Hibernate: WOL borked, resumes fine
>
> Linux, unpatched:
> Hibernate, shutdown method: Works with known caveats
> Hibernate, platform method: WOL borked,

That may be worth some investigation. However, since that doesn't work on
Windows too, I suspect the platform is slightly broken.

> resumes fine
>
> Linux, patched:
> Hibernate, shutdown method: Works
> Hibernate, platform method: WOL borked, resumes fine
> Suspend ('standby' state):
> WOL borked, USB borked after resume, kernel freeze
> Suspend ('mem' state, text console):
> WOL borked, VGA stays dark, otherwise working

You can try s2ram to bring the VGA to life, I think
(http://suspend.sf.net/s2ram-support.html).

> Suspend ('mem' state, radeonfb):
> WOL borked, VGA stays dark, userspace dead after resume (but pingable)
>
> Summary: I suspect my BIOS sucks

That's possible ...

> Version: ASUS M2N-SLI DELUXE ACPI BIOS Revision 0903
> Release Date: 02/13/2007
>
> 1 point for Linux, 0 points for Windows, Linux wins ;)

Thanks,
Rafael


\
 
 \ /
  Last update: 2008-05-21 00:45    [W:0.189 / U:0.580 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site