lkml.org 
[lkml]   [2008]   [Apr]   [9]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: DRM modesetting & sysfs
Date
On Wednesday, April 09, 2008 10:23 am Alan Hourihane wrote:
> On Wed, 2008-04-09 at 09:34 -0700, Jesse Barnes wrote:
> > On Wednesday, April 09, 2008 9:15 am Alan Hourihane wrote:
> > > On Wed, 2008-04-09 at 08:17 -0700, Jesse Barnes wrote:
> > > > On Wednesday, April 09, 2008 1:57 am Jakob Bornecrantz wrote:
> > > > > I was going to suggest that you plug it into the hotplug_stage_two
> > > > > function but it looks like you have already done that. Things might
> > > > > be routed differently now then since the last time I looked at the
> > > > > code, are you sure that stage_two is being run?
> > > >
> > > > I'll have to check, I'm not sure I'm even getting interrupts...
> > >
> > > Jesse,
> > >
> > > Is this i915 or i945/i965 you are testing on ??
> >
> > I've been testing on my i915 based laptop, haven't tried my other systems
> > yet...
>
> With VGA (i.e. ADPA) output ?
>
> If so, that's the problem. From what I can tell of i915 docs, they only
> support hotplug for SDVO devices only, so that's how it's coded up at
> the moment. For i945/i965 it can go the whole hog.

Ah, maybe that's it, yeah I'm using VGA via ADPA. I don't see any IIR or
PIPEASTAT bits set when I plug in the display, so I guess we're stuck with
manually probing on these devices.

Thanks,
Jesse


\
 
 \ /
  Last update: 2008-04-09 19:43    [from the cache]
©2003-2011 Jasper Spaans