lkml.org 
[lkml]   [2008]   [Apr]   [4]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: 2.6.25-current-git hangs on boot unless CONFIG_CPU_IDLE=n -Apple
On Fri  4.Apr'08 at  7:25:34 -0700, Pallipadi, Venkatesh wrote:
>
>
> >-----Original Message-----
> >From: linux-kernel-owner@vger.kernel.org
> >[mailto:linux-kernel-owner@vger.kernel.org] On Behalf Of
> >Carlos R. Mafra
> >Sent: Friday, April 04, 2008 4:48 AM
> >To: Ray Lee
> >Cc: Pallipadi, Venkatesh; Rafael J. Wysocki; Linux Kernel
> >Mailing List; Pallipadi@ogre.sisk.pl; Soeren Sonnenburg
> >Subject: Re: 2.6.25-current-git hangs on boot unless
> >CONFIG_CPU_IDLE=n -Apple
> >
> >On Thu 3.Apr'08 at 20:15:02 -0700, Ray Lee wrote:
> >> On Thu, Apr 3, 2008 at 6:10 PM, Carlos R. Mafra
> ><crmafra2@gmail.com> wrote:
> >> > On Thu 3.Apr'08 at 17:14:22 -0700, Pallipadi, Venkatesh wrote:
> >> > > >The following report is on the current list of known
> >regressions
> >> > > >from 2.6.24. Please verify if the issue is still
> >present in the
> >> > > >mainline.
> >> > > >
> >> > > >
> >> > > >Bug-Entry : http://bugzilla.kernel.org/show_bug.cgi?id=10093
> >> > > >Subject : 2.6.25-current-git hangs on boot
> >> > > >unless CONFIG_CPU_IDLE=n - Apple
> >> > > >Submitter : Soeren Sonnenburg <kernel@nn7.de>
> >> > > >Date : 2008-02-23 18:55 (41 days old)
> >> > > >References : http://lkml.org/lkml/2008/2/23/263
> >> > > >
> >> > > >http://marc.info/?l=linux-acpi&amp;m=120387537018467&amp;w=4
> >> > > >Handled-By : Pallipadi, Venkatesh
> ><venkatesh.pallipadi@intel.com>
> >> > > >
> >> > >
> >> > > Last comment I saw from Soeren says it does not really
> >hang. It waits
> >> > > for 5-10 seconds sometimes before continuing. We are
> >still trying to
> >> > > narrow this down with max_cstate etc..
> >> >
> >> > I should say that my laptop (Vaio) _hangs_ at boot (less
> >than 10% of boots)
> >> > and this is the last message I see:
> >> >
> >> > "ACPI: Processor [CPU1] (supports 8 throttling states)"
> >> >
> >> > and it stays there "forever" (more than 1 or 2 minutes at least).
> >> >
> >> > I am not using my laptop too much these days, and I thought this
> >> > bug had been solved because it didn't hang for the last week (but
> >> > I boot it once per day), however it hang last night (using some
> >> > post 2.6.25-rc7 kernel)
> >> >
> >> > I have pictures of the screen while showing this last
> >message at boot,
> >> > should I post it somewhere or that is not necessary?.
> >>
> >> If the sysrq key still works when that happens, try to do a sysrq-t,
> >> s, b to generate a trace, sync the filesystem, and reboot.
> >If anything
> >> made it to the logs, please post it.
> >
> >Sysrq keys don't work when it hangs, I have to push the power button.
> >
> >Another thing to notice is that when it happens, it usually happens
> >more times in a row (like 3 times). And then it can take many boots to
> >happen again.
> >
> >I've uploaded the picture where it hangs, it is in the very beginning
> >of the boot process:
> >
> >http://www.ift.unesp.br/users/crmafra/dsc04673.jpg
>
>
> Can you try the latest git and see whether this still is a problem?

I've just updated to latest git, but it may take some time for it
to happen again (the first 3 boots were okay). Last time it happened
with 2.6.25-rc7-00149-gaf8be4e (I checked now).

Do you have reasons to believe this issue was fixed since then?


\
 
 \ /
  Last update: 2008-04-04 17:55    [W:0.245 / U:3.656 seconds]
©2003-2017 Jasper Spaans. hosted at Digital OceanAdvertise on this site