lkml.org 
[lkml]   [2008]   [Mar]   [31]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    From
    SubjectRe: make O=dir fails with current git
    On Sat, Mar 29, 2008 at 07:19:21PM +0100, Stefan Hellermann wrote:
    > Hi,
    >
    > I'm using "make O=machinename" for building different kernels from one tree. About 15 days
    > ago it was okay, with current git it fails:
    > $ make O=client1
    > scripts/kconfig/conf -s arch/x86/Kconfig
    > Using /srv/devel/kernel as source for kernel
    > /srv/devel/kernel is not clean, please run 'make mrproper'
    > in the '/srv/devel/kernel' directory.
    > make[1]: *** [prepare3] Error 1
    > make: *** [sub-make] Error 2
    >
    > running "make mrproper" (without O=dir) doesn't help.
    > I've not changed anything, I only made a "git-pull".
    > Now I'm at home, tried "mkdir test; make O=test defconfig all" with current git-head, it
    > doesn't work too.

    I tried to reproduce this here without luck.
    The tests performed by kbuild to dertermine if the
    source directory is clean are very basic.
    If the file .config exist or the directory
    include/config exists then the source tree is considered clean.
    Otherwise you get the above message.

    Can you please try to run: make mrproper
    and then manually check if the .config file
    or the include/config directory exists.

    If they exists after make mrproper then
    check your permissions.

    In any case let me know the result.

    Sam


    \
     
     \ /
      Last update: 2008-03-31 20:03    [W:0.020 / U:35.880 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site