[lkml]   [2008]   [Mar]   [30]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [alsa-devel] [regression] 2.6.25-rc4 snd-es18xx broken on Alpha
Rene Herman wrote:
> (...) Bob
> seemed to be experiencing something else but this is pretty fundamental so
> I'll not try to comment on his case any further until he's had a chance to
> test this as well.
> (...)

> (miata_no_mmap.diff patch)

Made no difference for any of the "sox" tests, and "play" is still
broken in the way it always has been. However, "aplay" generated an
interesting error I haven't seen before:

$ aplay asskickd.wav
Playing WAVE 'asskickd.wav' : Unsigned 8 bit, Rate 11025 Hz, Mono
ALSA lib pcm_plug.c:773:(snd_pcm_plug_hw_refine_schange) Unable to find an usable access for 'default'
aplay: aplay.c:919: set_params: Assertion `err >= 0' failed.
Aborted by signal Aborted...

The ES18xx IRQ (5) is still not seeing any interrupt activity.

I *think* the only thing I haven't tried is Rene's patch that plays
around with the irqmask (es18xx_trial_and_error). I'll give that a
shot and report back as soon as possible.

Bob Tracy | "I was a beta tester for dirt. They never did | get all the bugs out." - Steve McGrew on /.

 \ /
  Last update: 2008-03-30 23:11    [W:0.064 / U:2.424 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site