lkml.org 
[lkml]   [2008]   [Mar]   [27]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    From
    SubjectRe: 2.6.25-rc7: Ugh.
    Jiri Kosina wrote:
    > On Thu, 27 Mar 2008, Greg KH wrote:
    >
    >>> It boots, but just a simple suspend/resume (RAM) was enough to kill
    >>> it. It comes back on resume, with an X desktop again, but with no USB
    >>> functionality -- no mouse.
    >>> The keyboard still works, so I dropped to a console and tried:
    >>> rmmod usbhid
    >>> insmod usbhid
    >>> And the console hung at 100% CPU on the insmod.
    >> Haven't heard of this one before sorry. Jiri, have you?
    >
    > No, haven't heard anything similar either. Mark, are you able to collect
    > the stacktraces via alt-sysrq-t at the time the system goes crazy?
    ..

    No where practical to capture them to.
    I don't know if the machine was entirely dead,
    or just the console at that point.

    > Also, as you seem to be able to easily reproduce the bug, git-bisect might
    > reveal the culprit easily. For start, you can try to bisect only let's say
    > usb, hid and acpi code probably ... ?
    ..

    I don't have the XX days necessary for git-bisect right now.
    But if there were some likely candidates, I could probably try a couple.
    Mostly I just wanted to give a heads-up that all is not well with 2.6.25
    for now, and I'll get round to debugging it when I have time to do so.

    I haven't yet tried -rc7 on my *other* dissimilar notebook,
    but back at -rc2 it also had serious issues with suspend/resume not working.
    This is my first look at 2.6.25 (on notebooks) since then.

    ..
    >>> kernel: [ 111.361099] pciehp_resume ENTRY
    >>> kernel: [ 112.362047] pciehp: Device 0000:0c:00.0 already exists at c:0,
    >>> cannot hot-add
    >>> kernel: [ 112.362052] pciehp: Cannot add device 0xc:0
    >
    > Hmm, what device is this?
    ..

    Wireless PCIe card on internal slot -- Intel 3945ABG.



    \
     
     \ /
      Last update: 2008-03-28 03:01    [W:0.024 / U:0.044 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site