lkml.org 
[lkml]   [2008]   [Mar]   [27]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: processor flags
[H. Peter Anvin - Thu, Mar 27, 2008 at 12:55:42PM -0700]
> Cyrill Gorcunov wrote:
>> And now I'm in confusion - the way of changing this code I see is the
>> following:
>> - or use additional #ifdef CONFIG_VM86 in code where VM_MASK is used
>> (that would be ugly IMHO)
>> - rename VM_MASK to say X86_EFLAGS_VM86 with that #ifdef remained
>> - rest VM_MASK as it is
>> How do you think?
>
> I think what we should do is:
>
> - Rename VM_MASK to X86_VM_MASK (it's x86-specific after all)
> - Have:
>
> #if CONFIG_VM86
> # define X86_VM_MASK X86_EFLAGS_VM
> #else
> # define X86_VM_MASK 0 /* No V86 support */
> #endif
>
> -hpa
>

Thanks a lot, Peter

- Cyrill -


\
 
 \ /
  Last update: 2008-03-27 21:01    [W:0.037 / U:0.840 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site