[lkml]   [2008]   [Mar]   [23]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
    SubjectRe: 2.6.25-git regression with snd-hda-intel on Dell XPS M1330, no analog sound
    Takashi Iwai wrote:
    > At Fri, 21 Mar 2008 20:03:32 +0100,
    > Andre Tomt wrote:
    >> [Rafael & Matthew: this is a resend - original was sent to wrong
    >> linux-kernel address. Also updated, so just ignore the earlier emails.]
    >> With 2.6.25-git I lost sound on my Dell XPS M1330 laptop. There seems to
    >> be two issues at hand here: 1. Analog output is listed, but emits no
    >> sound (just silence), and 2. Digital out device is missing.
    >> Issue #1 is bisected in this thread. #2 is still work in progress, and
    >> will be posted as a separate thread.
    > Please try my ALSA git tree
    > git://
    > One patch (removing master hack from headphone pin) would fix your
    > problem. At least, I have some reports that the latest ALSA tree
    > works. If it still doesn't work, give the output (the
    > script is found in "Debug" section).

    Yep. Analog out is working with sound-2.6.git. Thanks. What is the
    commit id of the removing master hack commit?

    > If the issue #2 is about HDMI, I'm afraid it won't work until Nvidia
    > video driver supports the HDMI audio output.

    I must admit I never tested it in Linux, and testing it now using 2.6.24
    I cannot get it to work either. In the windows drivers the port is
    simply labeled as a spdif output on the same codec, but I have no idea
    on how this is put together..

     \ /
      Last update: 2008-03-23 23:51    [W:0.032 / U:35.000 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site