[lkml]   [2008]   [Mar]   [21]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: 2.6.23-rc9-git4: pata_pcmcia, disabling IRQ #9 and Re: libata and legacy ide pcmcia failure
Alan Cox wrote:
> On Fri, 21 Mar 2008 10:38:31 +0900
> Tejun Heo <> wrote:
>> Alan Cox wrote:
>>> O> Mar 20 19:51:45 idefix kernel: ata12: PATA max PIO0 cmd 0xa100 ctl
>>>> 0xa10e irq 3
>>>> Mar 20 19:52:15 idefix kernel: ata12.00: qc timeout (cmd 0x91)
>>>> Mar 20 19:52:15 idefix kernel: ata12.00: failed to IDENTIFY
>>>> (INIT_DEV_PARAMS failed, err_mask=0x4)
>>> Thinkpad T61p .. I've seen a few of these.
>>> Firstly try the card and adapter in a different PC and let me know if
>>> that works. So far they do. If that is the case get the latest firmware
>>> updates (BIOS etc) for your thinkpad and see if the problem goes away.
>>> They (or our ACPI code I guess it may be) have some serious IRQ routing
>>> problems on this box.
>> Any chance the thing just chokes up on INIT_DEV_PARAMS?
> Possibly but I've seen several previosu reports showing no IRQ being
> delivered off these machines. You get IRQ 3 reported as assigned and an
> IRQ 9 turns up.
> Alan

Also, these devices used to work about a year ago (same machine, earlier
kernel) and then stopped working.

It is entirely possible that some change triggered a BIOS(?) bug, or
even that a BIOS upgrade caused the breakage, of course.

I'll try to try out the hardware in another Linux box - it may take a
while, as I have to find out who at work has liberated their machine
from corporate IT. :-)


 \ /
  Last update: 2008-03-21 12:35    [from the cache]
©2003-2014 Jasper Spaans. hosted at Digital Ocean