lkml.org 
[lkml]   [2008]   [Mar]   [14]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: [alsa-devel] [regression] 2.6.25-rc4 snd-es18xx broken on Alpha
Date
On Fri March 14 2008, Bob Tracy wrote:
> A quick followup... Since we're in agreement this isn't a regression,
> I've updated my working source tree to 2.6.25-rc5. Built the new
> kernel with the patch to omit es1888_init(), and as near as I can tell,
> that function does nothing useful on the Miata platform. At the very
> least, not having it makes no difference to any of the ALSA drivers I've
> tried: snd-sb8 still works great, and snd-es18xx is still broken in the
> same way originally described at the beginning of this long thread.
>
> I'll try a build with the old OSS "sb" driver, and if that works ok, we
> may be able to do away with es1888_init() on the Miata. Tyson -- I
> think you have a Miata if I'm remembering correctly: can you confirm
> these observations?

I actually ran into some problems with my Alpha, and I haven't managed to get
get it full operational again yet. I replaced the CPU fan, installed the new
aboot, and left it trying to recover the filesystems. It was an unhappy
story all around -- damn that CMD646 chipset, I was under the impression that
driver had acquired some recent fixups. Anyway, if this succeeds, I'll try
and compile up a new kernel with the patch when I get a chance.

With regard to the sound driver, the es18xx does endless looping on the first
second or so of sound on my box (a PWS500au) unless I apply my patch, which
just enables the alternative interupt detection code in the driver. Even
then, though, I believe it still only works in 8bit mode.

The sb8 driver also works for me. For this reason, I basically decided to
forget about my es18xx patch. It doesn't get me anything the sb8 driver
doesn't give me, and it forces me to keep compiling my own kernels.

Cheers! -Tyson

PS: The Debian 2.6.24 kernel actually panicked on me (instead of infinitely
looping on the first second of sound) when I tried the stock es18xx driver.

--
Tyson Whitehead (-twhitehe at uwo.ca -- MC-)
Computer Engineer Dept. of Applied Mathematics,
Graduate Student- Applied Mathematics University of Western Ontario,
GnuPG Key ID# 0xF7666BFF London, Ontario, Canada
[unhandled content-type:application/pgp-signature]
\
 
 \ /
  Last update: 2008-03-15 02:27    [W:0.087 / U:30.776 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site