[lkml]   [2008]   [Mar]   [14]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH] x86: simplify sync_test_bit()
Jan Beulich wrote:
> I'm usually intentionally using just the names, without parameters and
> not as inline, in such alias definitions so that in case the name gets used
> as a function pointer (arguably unlikely here) there's not going to be
> any missing definition or duplicate function instantiation. But from a
> functionality point of view, either of the alternatives you suggest is
> of course as good.

I'm especially wary of the naked #define, since it will affect any
instance of sync_test_bit:

struct bit_thingy {
unsigned sync_test_bit:1;
unsigned other_test_bit:1;


 \ /
  Last update: 2008-03-14 16:47    [W:0.031 / U:36.460 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site