lkml.org 
[lkml]   [2008]   [Mar]   [12]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: [PATCH 1/6] kernel: add clamp(), clamp_t() and clamp_val() macros
Date
On Wednesday 12 March 2008 17:54:26 Harvey Harrison wrote:
> On Wed, 2008-03-12 at 16:13 +0100, Michael Buesch wrote:
> > So why not call it clamp_const()?
> > One could even use __builtin_constant_p() and make clamp() use
> > either clamp_const() or clamp_nonconst() from above automagically.
> > I'd prefer that.
>
> Did you mean something like this? No more clamp_val, just clamp and
> clamp_t. clamp_t forces all the types, clamp looks at the min and max
> args, and if they are constants, uses the type of val instead. If not
> a constant, the strict typechecking is done.

> +#define clamp(val, min, max) ({ \
> + typeof(val) __val = (val); \
> + \
> + if (__builtin_constant_p(min)) { \
> + typeof(val) __min = (min); \
> + __val = __val < __min ? __min: __val; \
> + } else { \
> + typeof(min) __min = (min); \
> + (void) (&__val == &__min); \
> + __val = __val < __min ? __min: __val; \
> + } \
> + \
> + if (__builtin_constant_p(max)) { \
> + typeof(val) __max = (max); \
> + __val > __max ? __max: __val; \
> + } else { \
> + typeof(max) __max = (max); \
> + (void) (&__val == &__max); \
> + __val > __max ? __max: __val; \
> + } })

Yeah, something like that.
Does returning of the value work over an indentation level, too?
I dunno this detail of the language.
But I'd prefer the following for readability anyway:

+ if (__builtin_constant_p(max)) { \
+ typeof(val) __max = (max); \
+ __val = __val > __max ? __max: __val; \
+ } else { \
+ typeof(max) __max = (max); \
+ (void) (&__val == &__max); \
+ __val = __val > __max ? __max: __val; \
+ }
+ __val; })

Probably you can also only put the pointer check into the constant check:

+#define clamp(val, min, max) ({ \
+ typeof(val) __val = (val); \
+ typeof(min) __min = (min); \
+ typeof(max) __max = (max); \
+ if (!__builtin_constant_p(min)) \
+ (void) (&__val == &__min); \
+ __val = __val < __min ? __min: __val; \
+ if (!__builtin_constant_p(max)) \
+ (void) (&__val == &__max); \
+ __val = __val > __max ? __max: __val; \
+ __val; })

But it seems that this evaluates the arguments twice, so my idea turns out
to be not too good anyway. hm..

--
Greetings Michael.


\
 
 \ /
  Last update: 2008-03-12 18:23    [W:0.203 / U:0.500 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site