lkml.org 
[lkml]   [2008]   [Mar]   [12]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: [PATCH 1/6] kernel: add clamp(), clamp_t() and clamp_val() macros
Date
On Tuesday 11 March 2008 22:11:34 Harvey Harrison wrote:
> Adds macros similar to min/max/min_t/max_t.
>
> Also, change the variable names used in the min/max macros to
> avoid shadowed variable warnings when min/max min_t/max_t are
> nested.
>
> clamp_val is useful when clamping to constants so all types are
> taken from typeof() the first arg.
>
> Small formatting changes to make all the macros have a similar
> form.
>
> Signed-off-by: Harvey Harrison <harvey.harrison@gmail.com>
> ---
> Andrew, this is a rollup of my original patch already in -mm with
> checkpatch warnings fixed up and one additional macro based on
> limit_value found in the b43 driver, called clamp_val.
>
> clamp_t is no longer used, but I introduce it anyway as some future
> user may want to force the return type similar to how min_t/max_t
> operate.
>
> include/linux/kernel.h | 66 ++++++++++++++++++++++++++++++++++-------------
> 1 files changed, 48 insertions(+), 18 deletions(-)
>
> diff --git a/include/linux/kernel.h b/include/linux/kernel.h
> index 2df44e7..b9331ac 100644
> --- a/include/linux/kernel.h
> +++ b/include/linux/kernel.h
> @@ -335,33 +335,63 @@ static inline int __attribute__ ((format (printf, 1, 2))) pr_debug(const char *
> #endif /* __LITTLE_ENDIAN */
>
> /*
> - * min()/max() macros that also do
> + * min()/max()/clamp() macros that also do
> * strict type-checking.. See the
> * "unnecessary" pointer comparison.
> */
> -#define min(x,y) ({ \
> - typeof(x) _x = (x); \
> - typeof(y) _y = (y); \
> - (void) (&_x == &_y); \
> - _x < _y ? _x : _y; })
> -
> -#define max(x,y) ({ \
> - typeof(x) _x = (x); \
> - typeof(y) _y = (y); \
> - (void) (&_x == &_y); \
> - _x > _y ? _x : _y; })
> +#define min(x, y) ({ \
> + typeof(x) _min1 = (x); \
> + typeof(y) _min2 = (y); \
> + (void) (&_min1 == &_min2); \
> + _min1 < _min2 ? _min1 : _min2; })
> +
> +#define max(x, y) ({ \
> + typeof(x) _max1 = (x); \
> + typeof(y) _max2 = (y); \
> + (void) (&_max1 == &_max2); \
> + _max1 > _max2 ? _max1 : _max2; })
> +
> +#define clamp(val, min, max) ({ \
> + typeof(val) __val = (val); \
> + typeof(min) __min = (min); \
> + typeof(max) __max = (max); \
> + (void) (&__val == &__min); \
> + (void) (&__val == &__max); \
> + __val = __val < __min ? __min: __val; \
> + __val > __max ? __max: __val; })
> +
> +/*
> + * Useful when min and max are constants.
> + */
> +#define clamp_val(val, min, max) ({ \

So why not call it clamp_const()?
One could even use __builtin_constant_p() and make clamp() use
either clamp_const() or clamp_nonconst() from above automagically.
I'd prefer that.

> + typeof(val) __val = (val); \
> + typeof(val) __min = (min); \
> + typeof(val) __max = (max); \
> + __val = __val < __min ? __min: __val; \
> + __val > __max ? __max: __val; })
>
> /*
> * ..and if you can't take the strict
> * types, you can specify one yourself.
> *
> - * Or not use min/max at all, of course.
> + * Or not use min/max/clamp at all, of course.
> */
> -#define min_t(type,x,y) \
> - ({ type __x = (x); type __y = (y); __x < __y ? __x: __y; })
> -#define max_t(type,x,y) \
> - ({ type __x = (x); type __y = (y); __x > __y ? __x: __y; })
> -
> +#define min_t(type, x, y) ({ \
> + type __min1 = (x); \
> + type __min2 = (y); \
> + __min1 < __min2 ? __min1: __min2; })
> +
> +#define max_t(type, x, y) ({ \
> + type __max1 = (x); \
> + type __max2 = (y); \
> + __max1 > __max2 ? __max1: __max2; })
> +
> +#define clamp_t(type, val, min, max) ({ \
> + type __val = (val); \
> + type __min = (min); \
> + type __max = (max); \
> + __val = __val < __min ? __min: __val; \
> + __val > __max ? __max: __val; })
>
> /**
> * container_of - cast a member of a structure out to the containing structure



--
Greetings Michael.


\
 
 \ /
  Last update: 2008-03-12 16:17    [W:0.115 / U:0.360 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site