lkml.org 
[lkml]   [2008]   [Feb]   [3]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [BUG] 2.6.24 refuses to boot - ATA problem?

* Gene Heskett <gene.heskett@gmail.com> wrote:

> I believe its the same, but lemme paste it for sure, yes:
> [ 26.339926] ENABLING IO-APIC IRQs
> [ 26.340119] ..TIMER: vector=0x31 apic1=0 pin1=0 apic2=-1 pin2=-1
> [ 26.350129] ..MP-BIOS bug: 8254 timer not connected to IO-APIC
> [ 26.350182] ...trying to set up timer (IRQ0) through the 8259A ... failed.
> [ 26.350185] ...trying to set up timer as Virtual Wire IRQ... failed.
> [ 26.360186] ...trying to set up timer as ExtINT IRQ... works.
>
> The third line is the only line that makes it to the screen during the
> boot trace.
>
> Now, what does this tell us?

the question would be:

- if you remove the acpi_use_timer_override boot flag
- and if you boot a kernel with this hack applied

=> do those weird PATA failures come back?

If the failues do _not_ come back then the problem is somehow
affected/worked-around by the IO-APIC code that generates the above 4
lines. If the failures are still the same then the above 4 lines are
really just an uninteresting side-effect of the acpi_use_timer_override
flag - and the real side-effects (that fixes PATA on your box) are to be
found elsewhere.

Sadly, the latter variant is the expected answer.

Ingo


\
 
 \ /
  Last update: 2008-02-03 07:01    [W:0.049 / U:7.436 seconds]
©2003-2017 Jasper Spaans. hosted at Digital OceanAdvertise on this site