lkml.org 
[lkml]   [2008]   [Feb]   [25]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    From
    SubjectRe: IDE cdrom problem with PLEXTOR DVDR PX-608AL
    Hi Boris,

    > Well, this sounds strange. Are you sure you're entering the boot options
    > correctly on the kernel command line? Which is your boot loader? I just booted
    > my machine with 'hdc=noprobe' (hdc is my cdrom drive) and here's what i get:
    >
    > ...
    > [ 0.304774] Probing IDE interface ide0...
    > [ 0.569359] hdb: SAMSUNG SP2014N, ATA DISK drive
    > [ 0.613977] Switched to NOHz mode on CPU #1
    > [ 0.773368] Switched to NOHz mode on CPU #0
    > [ 0.874486] hda: QUANTUM FIREBALLlct10 20, ATA DISK drive
    > [ 0.874506] hda: host max PIO4 wanted PIO255(auto-tune) selected PIO4
    > [ 0.874506] hda: drive side 80-wire cable detection failed, limiting max speed to UDMA33
    > [ 0.874506] hda: UDMA/33 mode selected
    > [ 0.874533] hdb: host max PIO4 wanted PIO255(auto-tune) selected PIO4
    > [ 0.874620] hdb: UDMA/100 mode selected
    > [ 0.874744] Probing IDE interface ide1...

    > so it seems you should check whether your kernel is receiving the 'hda=noprobe'
    > boot option at all, or something along that path is going wrong...

    I'm entering the option 'hda=noprobe' (as one example) right after my boot
    label in LILO. The dmesg output I attached last time was a boot of straight
    2.6.25-rc2 without any options; I've attached 'dmesg.noprobe.out' which is
    the result of a boot with 'hda=noprobe'.

    I must have done something stupid, but I can't see what; if you look at this
    line from the dmesg output:

    Kernel command line: BOOT_IMAGE=linux_2.6.25rc2 ro root=900
    md=0,/dev/sda5,/dev/sdb5 hda=noprobe

    ... it would suggest the option 'hda=noprobe' was entered correctly?

    > > I tried to apply the patch but failed; I probably did something wrong.
    > > I deleted everything in your message above 'Index: b/drivers/ide/ide-cd.c'
    > > and ran 'patch --dry-run -b -p1 < ../bart_patch'. This is part of my script
    > > log:
    >
    > are you sure you're _really_ using 2.6.25-rc2? Applying the patch against that
    > kernel works just fine, no fuzziness or even rejects. Care to try out on a fresh
    > kernel source tarball? After all, building a kernel with your quad core cpu won't
    > take that long :-) when using make -j8 or something in that order.

    Heh. This is my first new machine in 8 years, and I couldn't wait to start
    using multiple cores. I was quick to discover the '-j' option ... but I only
    do '-j 4'. Anyway ... I'd downloaded the full baseline linux-2.6.24.tar.bz2,
    unpacked it, and then ran the patch patch-2.6.25-rc2.bz2 against it. That
    patch ran perfectly. And I was in the right directory when I ran Bart's patch,
    as I listed in my earlier e-mail! All indications were that I was running the
    2.6.25-rc2 kernel as required, I thought.

    Well, I see that rc3 is out; maybe I'll give that a shot.


    Brad
    [unhandled content-type:application/octet-stream]
    \
     
     \ /
      Last update: 2008-02-25 06:59    [W:0.027 / U:29.952 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site