lkml.org 
[lkml]   [2008]   [Feb]   [2]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [BUG] 2.6.24 refuses to boot - ATA problem?

* Ingo Molnar <mingo@elte.hu> wrote:

> > [ 27.097095] ENABLING IO-APIC IRQs
> > [ 27.097287] ..TIMER: vector=0x31 apic1=0 pin1=2 apic2=-1 pin2=-1
> > [ 27.107291] ..MP-BIOS bug: 8254 timer not connected to IO-APIC
> > [ 27.107343] ...trying to set up timer (IRQ0) through the 8259A ... failed.
> > [ 27.107346] ...trying to set up timer as Virtual Wire IRQ... failed.
> > [ 27.117353] ...trying to set up timer as ExtINT IRQ... works.
> >
> > The last 4 lines above are not logged without that argument. So my
> > theory ATM is that this forced the kernel to initialize something in
> > the boards registers that it does not initialize without that
> > command, and that its going fubar as shown in the msg quoted above
> > is a totally random thing, perhaps dependent on the phase of one of
> > jupiters moons as to what state it powers up in. And I got lucky,
> > so far in that my single powerdown reset didn't trigger it again...
> > And you _know_ what that knocking sound is by now. :)
>
> that's weird. Could you try the hack below and _remove_ the
> acpi_use_timer_override flag? The change should artificially cause the
> above 4 lines to appear again, in all cases.
>
> This would test the following aspects of your theory: is this unknown
> side-effect of the the acpi_use_timer_override flag related to the
> timer setup sequence in io_apic_32.c? If not, then the difference most
> likely lies in the different ACPI setup sequence.

i tried that patch on a box here, and it produces similar 4 lines:

[ 0.172141] ENABLING IO-APIC IRQs
[ 0.175498] init IO_APIC IRQs
[ 0.176059] IO-APIC (apicid-pin) 2-16, 2-17, 2-18, 2-19, 2-20, 2-21, 2-22, 2-23 not connected.
[ 0.187942] ..TIMER: vector=0x31 apic1=0 pin1=0 apic2=-1 pin2=-1
[ 0.233859] ..MP-BIOS bug: 8254 timer not connected to IO-APIC
[ 0.236014] ...trying to set up timer (IRQ0) through the 8259A ... failed.
[ 0.236014] ...trying to set up timer as Virtual Wire IRQ... failed.
[ 0.236014] ...trying to set up timer as ExtINT IRQ... works.
[ 0.277879] Using local APIC timer interrupts.

but ... in all likelyhood it's some ACPI side-effects of the
acpi_use_timer_override flag, not really this IO-APIC/timer-setup detail
that matters.

Ingo


\
 
 \ /
  Last update: 2008-02-03 05:53    [W:0.055 / U:0.452 seconds]
©2003-2017 Jasper Spaans. hosted at Digital OceanAdvertise on this site