[lkml]   [2008]   [Feb]   [11]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [2.6.25-rc1 regression] Suspend to RAM (bisected)
On Mon, 2008-02-11 at 03:25 -0200, Carlos R. Mafra wrote: 
> Hi,
> I want to report that suspend to RAM stopped working on my Sony Vaio
> VGN-FZ240E in 2.6.25-rc1 and that I could bisect the problem down
> to:
> commit bc71bec91f9875ef825d12104acf3bf4ca215fa4
> Author: <>
> Date: Thu Jan 31 17:35:04 2008 -0800
> ACPI: enable MWAIT for C1 idle

I normally hate to throw in a 'me-too', but I'm also seeing a
suspend-to-ram regression on my Thinkpad R61i that I've managed to
bisect down to the same patch series.

You beat me emailing the issue to the list by a few minutes :)

> The problem with suspend to RAM is that right after typing (from inside X)
> 'echo mem > /sys/power/state' the screen becomes black and the laptop
> freezes. I have to use SysRq+b to reboot.

My symptoms in this case are slightly different - the suspend appears to
work correctly, and is fast. However, when I resume, the screen lights
up quickly, but the system hangs for nearly a minute with the suspend
light still on solid before it actually resumes. No delay is visible in
dmesg; this apparently happens before the "return to C".

> I tried to revert the above commit (bc71bec) on top of 2.6.25-rc1, but
> the compilation fails. It turns out that I have to revert also 9a0b8415 and
> 9b12e18c to be able to compile without errors.
> After reverting the 3 commits mentioned above, the resulting 2.6.25-rc1 kernel
> can suspend to RAM again (and I must say that it is better that 2.6.24, because
> now it resumes directly into X and I don't need to use Crtl-Alt-F1 and Alt-F7 to
> go back to X as I used to do before).

I just tried reverting the above-mentioned 3 commits, doing so fixes the

> The laptop is a Core 2 Duo T7250 2.0 GHz, running Mandriva 2008.0 in 64-bit mode, with the
> following graphics card:
> VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c) (prog-if 00 [VGA])

Rather similar system - I have a core 2 duo 1.5 running x86_64 gentoo,
and a GM965 chip (using uvesafb)

> If there is anything else I can do to help please let me know.
> Carlos R. Mafra

Calvin Walton <>

 \ /
  Last update: 2008-02-11 06:55    [W:0.092 / U:2.100 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site