[lkml]   [2008]   [Dec]   [8]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
    SubjectNasty regression from .27.7 to .27.8: idle samba goes crazy


    I just encountered a nasty symptom for the second time that has started to
    occur after updating my home server from vanilla to .8 (same

    A while after disconnecting a samba client, the smbd samba server
    process goes crazy and consumes 100% CPU. From that time on it is
    unkillable (kill -9 returns but the process continues to run). The only
    recourse is reboot, which works without problem (i.e. unmounting the
    served filesystems is apparently possible?). I tried to attach to the
    process with gdb but that just hung.

    The system is a generic old single-core P4 box with a single SATA drive,
    Gentoo userland and Samba is 3.0.33 (in async mode). The kernel has no
    patches or binary drivers. It has been rock solid before the update and
    shows no other signs of weirdness in logs or otherwise. I downgraded to .7
    for now and will see what happens, but since it worked before I am certain
    that this is a regression in the .8 release.

    The only commonality is a log entry by samba that seems to correlate with
    both occurrences:

    [2008/12/08 01:02:52, 0] lib/util_sock.c:read_data(534)
    read_data: read failure for 4 bytes to client Error = No route to host

    .128 is the Windows client machine (connected via a stable GigE link),
    which I shut down pretty much exactly 30 minutes before that (any 30
    minute timeouts in the kernel/network stack?). Both instances of these log
    entries correlate with the CPU spikes which I noticed in my MRTG graphs.

    Any suspects or ideas?


     \ /
      Last update: 2008-12-08 07:21    [W:0.022 / U:129.988 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site