lkml.org 
[lkml]   [2008]   [Dec]   [4]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [patch] export percpu cpuacct cgroup stats
(I guess it's more appropriate to ask Ingo to pick up this patch)

Ken Chen wrote:
> This patch export per-cpu CPU cycle usage for a given cpuacct cgroup.
> There is a need for a user space monitor daemon to track group CPU
> usage on per-cpu base. It is also useful for monitor CFS load
> balancer behavior by tracking per CPU group usage.
>
>
> Signed-off-by: Ken Chen <kenchen@google.com>
>
> diff --git a/kernel/sched.c b/kernel/sched.c
> index b7480fb..cd78948 100644
> --- a/kernel/sched.c
> +++ b/kernel/sched.c
> @@ -9345,12 +9345,34 @@ out:
> return err;
> }
>
> +static int cpuacct_percpu_seq_read(struct cgroup *cgroup, struct cftype *cft,
> + struct seq_file *m)
> +{
> + struct cpuacct *ca = cgroup_ca(cgroup);
> + u64 percpu;
> + int i;
> +
> + for_each_possible_cpu(i) {
> + spin_lock_irq(&cpu_rq(i)->lock);
> + percpu = *percpu_ptr(ca->cpuusage, i);
> + spin_unlock_irq(&cpu_rq(i)->lock);
> + seq_printf(m, "%lld ", percpu);

Should be %llu. And if we don't cast percpu to unsigned long long, will it trigger
compile warning in some archs?

> + }
> + seq_printf(m, "\n");
> + return 0;
> +}
> +
> static struct cftype files[] = {
> {
> .name = "usage",
> .read_u64 = cpuusage_read,
> .write_u64 = cpuusage_write,
> },
> + {
> + .name = "percpu",

IMO percpu_usage is a better name.

> + .read_seq_string = cpuacct_percpu_seq_read,
> + },
> +
> };
>


\
 
 \ /
  Last update: 2008-12-04 06:39    [W:0.052 / U:0.112 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site