lkml.org 
[lkml]   [2008]   [Dec]   [16]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: time_is_after_jiffies misnomer
Date
"Also sprach Johannes Weiner:"
> On Tue, Dec 16, 2008 at 12:31:41PM +0100, Peter T. Breuer wrote:
> >
> > I thought at first that
> >
> > time_is_after_jiffies(foo)
> >
> > meant that the current time is later than foo jiffies.
>
> 'foo jiffies'?


?? What does that mean? Yes, "the current time is later than foo
jiffies", is what I wrote. I don't understand why you query it. What I
wrote is a perfectly normal english sentence. It means "if the current
time is X and and the

> It behaves like all the other time_(after|before) macros. "Compare a
> given time T against some other time X".

It's poor english. Yes, to an english speaker

time_is_after_jiffies(foo)

looks like

the current time is later than foo jiffies

Look at the two:

the current time is later than foo jiffies
| | | `/.
time_is_after_jiffies(foo)

(I AM a native english speaker, and a very good one - please take this
on board and pay attention to it; you'll find me quoted as the author
of hundreds of technical articles on google :-).

The mathematical "jiffies(foo)" for colloquial "foo jiffies" is the
normal way of writing formal predicates. Like "colour(red)" for
"red colour". This is a predicate.

> T is always the first argument to these macros, it's never the current
> time. This is consistent.

That's surely not relevant since it's the macro name that we are talking
about, nothing else.

As to "these macros", I see and know of no macros other than the set I
am commenting on. If you mean some others, you'll have to point them
out to me, but it wouldn't invalidate the observation: the macro names
are phrased the wrong way round for a natural english interpretation.


> And jiffies, the X here, is a well-known global variable. :)


> The banner comment above the macro group should have clarified the
> misunderstanding, btw.

No, it says nothing:

* These four macros compare jiffies and 'a' for convenience.

What's written above the individual macros is more explanatory, but
it's the NAMES of the macros that are the wrong way round for english:


/* time_is_before_jiffies(a) return true if a is before jiffies */
#define time_is_before_jiffies(a) time_after(jiffies, a)

It's time_is_before_jiffies(foo) that reads the wrong way round in
english. It should be


current_time_is_after_jiffies(foo).

Best regards


Peter




\
 
 \ /
  Last update: 2008-12-16 16:21    [W:0.080 / U:2.448 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site