lkml.org 
[lkml]   [2008]   [Nov]   [7]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 1/5] adt7462: New hwmon driver
On Fri, Nov 07, 2008 at 11:27:31AM -0800, Andrew Morton wrote:
> > > +#define ROUND_DIV(x, divisor) (((x) + ((divisor) / 2)) / (divisor))
> >
> > DIV_ROUND_UP ?
>
> That's different. This one should be called ROUND_CLOSEST or something
> like that.

Actually, there _is_ such a macro in include/linux/kernel.h, but it does
a double-eval naughty just like mine. That said, no need to bloat the
source tree, so I can reroll, and possibly even fix the kernel macro.

--D


\
 
 \ /
  Last update: 2008-11-07 20:37    [from the cache]
©2003-2011 Jasper Spaans