lkml.org 
[lkml]   [2008]   [Nov]   [5]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectAACRAID: Adaptec 2120S/2200S with +4GB RAM broken since 2.6.24, still not fixed
Date
Hi,

This has been discussed before; servers with Adaptec 2120S and 2200S
(and maybe others) are broken since 2.6.24 on systems with >4GB RAM. The
following commit (meant to make some PowerEdge controllers work) broke it:

http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=94cf6ba11b068b8a8f68a1e88bffb6827e92124b

It is not clear in the related bugtracker on which basis all those
controllers were given the AAC_QUIRK_SCSI_32 flag but it definitely
break at least two of them, possibly others. There's multiple reports of
it, threads in this and others mailing list, bug reports to various
distributions, but still no fix!

Tomas Henzl from Redhat posted a patch here nearly one moth ago (just
before 2.6.27) which didn't get picked up for 2.6.28:

http://lkml.org/lkml/2008/10/7/164

Other references:

http://bugzilla.kernel.org/show_bug.cgi?id=9133
https://bugzilla.redhat.com/show_bug.cgi?id=453472
https://bugzilla.redhat.com/show_bug.cgi?id=457552

Some more interesting links:
http://marc.info/?l=linux-kernel&m=122166454808377&w=2


You can also search this on Google for even more reports:
AAC_QUIRK_SCSI_32
"aac_fib_send failed with status 8195"

Thanks,

Thomas



\
 
 \ /
  Last update: 2008-11-06 04:35    [W:0.023 / U:0.332 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site