lkml.org 
[lkml]   [2008]   [Nov]   [3]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] power_supply: only register tosa_battery driver on tosa
2008/11/3 Anton Vorontsov <avorontsov@ru.mvista.com>:
> On Sun, Nov 02, 2008 at 11:36:08PM +0300, Dmitry wrote:
>> 2008/10/29 Dmitry Baryshkov <dbaryshkov@gmail.com>:
>> > There are already several wm97xx-battery drivers. Do register the tosa one
>> > only on tosa machines.
>> >
>> > Signed-off-by: Dmitry Baryshkov <dbaryshkov@gmail.com>
>> > ---
>> > drivers/power/tosa_battery.c | 3 +++
>> > 1 files changed, 3 insertions(+), 0 deletions(-)
>>
>> What about this patch?
>
> Sorry for the delay.
>
>> IMO it can and should be merged during 2.6.28-rc cycle.
>>
>> diff --git a/drivers/power/tosa_battery.c b/drivers/power/tosa_battery.c
>> index 2eab35a..4e52c22 100644
>> --- a/drivers/power/tosa_battery.c
>> +++ b/drivers/power/tosa_battery.c
>> @@ -469,6 +469,9 @@ static struct platform_driver tosa_bat_driver = {
>>
>> static int __init tosa_bat_init(void)
>> {
>> + if (!machine_is_tosa())
>> + return -EINVAL;
>> +
>
> I tend to reject this approach. You should rename the driver instead.
>
> I.e.
> -.driver.name = "wm97xx-battery",
> -.driver.name = "tosa-battery",
>
> And make sure that this won't break users of that driver (though
> I don't see any).

The wm97xx-battery device is registered by
drivers/input/toucscreen/wm97xx-core.c

>
>> return platform_driver_register(&tosa_bat_driver);
>> }
>
> Thanks,
>
> --
> Anton Vorontsov
> email: cbouatmailru@gmail.com
> irc://irc.freenode.net/bd2
>



--
With best wishes
Dmitry


\
 
 \ /
  Last update: 2008-11-03 17:23    [W:0.117 / U:0.096 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site